photo_admin
Auteur : Clément MICHEL
Niveau de difficulté : Confirmés
Licence :
licence

Résumés de routes avec EIGRP.

Explications :

EIGRP résume, par défaut, les routes afin de préserver les tables de routage. C’est la fonction auto-summary qui permet ce résumé automatique. Cette fonction peut, pourtant, causer des problèmes en cas de réseaux non contigus. Nous allons donc apprendre à désactiver cette fonction et paramétrer nous-même nos résumés de routes avec EIGRP !

Topologie :

Topologie du tutoriel

Préparation :

  • Toutes les interfaces sont correctement configurées.
  • Le routeur WEB est déjà configuré et effectue du routage EIGRP.
  • Les différents LAN sont opérationnels.
  • L'interconnexion entre WEB et TUTOS est fonctionnelle.

Téléchargez le fichier support (Packet Tracer) :

Current configuration : 663 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname WEB
!
interface FastEthernet0/0
 ip address 172.16.0.126 255.255.255.128
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 no ip address
 shutdown
!
interface Serial0/0/1
 ip address 10.0.0.2 255.255.255.252
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 1
 network 172.16.0.0 0.0.0.127
 network 10.0.0.0 0.0.0.3
 no auto-summary
!
ip classless
!
line con 0
line vty 0 4
 login
!
end
Current configuration : 609 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname TUTOS
!
interface FastEthernet0/0
 ip address 192.168.1.254 255.255.254.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.2.62 255.255.255.192
 duplex auto
 speed auto
!
interface Serial0/0/0
 ip address 10.0.0.1 255.255.255.252
 clock rate 128000
!
interface Serial0/0/1
 no ip address
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
!
line con 0
line vty 0 4
 login
!
end

Configuration des deux routeurs :

Réalisation :

Note : Le résumé de route pour les réseaux 192.168.0.0/23 et 192.168.2.0/26 est 192.168.0.0/22.

Étapes de la configuration :

  1. Configurer EIGRP sur le routeur TUTOS.
    TUTOS>enable
    TUTOS#configure terminal
    TUTOS(config)#router eigrp 1
    
  2. Désactiver la fonction de résumés automatiques.
    TUTOS(config-router)#no auto-summary
    
  3. Revenir au mode de configuration du terminal.
    TUTOS(config-router)#exit
    
  4. Configurer l'interface qui va annoncer les mises à jours aux autres routeurs (ici : se 0/0/0).
    TUTOS(config)#interface serial 0/0/0
    TUTOS(config-if)#ip summary-address eigrp 1 192.168.0.0 255.255.252.0
    TUTOS(config-if)#exit
    
  5. Compléter EIGRP et configurer les réseaux directement connectés (pensez à bien utiliser le résumé de route pour les réseaux 192.168.0.0/23 et 192.168.2.0/26).
    TUTOS(config)#router eigrp 1
    TUTOS(config-router)#network 192.168.0.0 0.0.3.255
    TUTOS(config-router)#network 10.0.0.0 0.0.0.3
    TUTOS(config-router)#end
    

Information : La commande ip summary-address eigrp 1 192.168.0.0 255.255.252.0 nous permet d'annoncer le résumé de routes aux autres routeurs du réseau. Il est important de configurer chaque interface susceptible d'envoyer des mises à jours.
Cette commande créera une route virtuelle dans la table de routage du routeur TUTOS. Elle sera, cependant, considérée comme une vraie route par les autres routeurs du réseau.

Il est important de noter que cette route prend, de façon automatique, une valeur de 5 concernant la Distance Administrative (cela ne concerne que le routeur sur lequel on effectue le résumé de route, TUTOS dans notre exemple).
Voici la syntaxe complète de la commande :

ip summary-address eigrp {Numéro du Système Autonome (1-65535)} [Adresse du résumé de routes] [Masque du résumé de routes] {Distance Administrative (1-255)}

Les tables de routage :

Voici l'impact mesuré sur les tables de routages après cette modification :

TUTOS :

TUTOS#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/30 is subnetted, 1 subnets
C       10.0.0.0 is directly connected, Serial0/0/0
     172.16.0.0/25 is subnetted, 1 subnets
D       172.16.0.0 [90/2172416] via 10.0.0.2, 00:17:59, Serial0/0/0
D    192.168.0.0/22 is a summary, 00:17:59, Null0
C    192.168.0.0/23 is directly connected, FastEthernet0/0
     192.168.2.0/26 is subnetted, 1 subnets
C       192.168.2.0 is directly connected, FastEthernet0/1
WEB :
WEB#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/30 is subnetted, 1 subnets
C       10.0.0.0 is directly connected, Serial0/0/1
     172.16.0.0/25 is subnetted, 1 subnets
C       172.16.0.0 is directly connected, FastEthernet0/0
D    192.168.0.0/22 [90/2172416] via 10.0.0.1, 00:17:06, Serial0/0/1