photo_admin
Auteur : Clément MICHEL
Niveau de difficulté : Experts
Licence :
licence

Provider Bridge Network (QinQ)

Prérequis : Connaissances sur la technologie VLAN (Conférence disponible ici).

Mais que veux dire ce nom "barbare" ?
Le QinQ permet de faire des VLANs empilés. La norme 802.1q permet l'utilisation des VLANs, elle ajoute 4 octets dans l'en-tête de trame répartis sur deux champs :

  • TPI : Tag Protocol Identifier. Il est codé sur deux octets et permet l'identification du type de trame Ethernet.
    La valeur hexadécimale de ce champ est 0x8100.
  • TCI : Tag Control Information. Il est codé sur deux octets et permet l'identification du VLAN (on parle de VLAN Tag) ainsi qu'une éventuelle priorité si une politique de QoS existe.

Format de trame Ethernet sous la norme 802.1q :

dot1q

Afin d'augmenter le nombre de VLANs (limité à 4096) ou encore de faciliter la propagation entre différents sites on peut utiliser la norme 802.1ad (aussi connue sous le nom de "QinQ") qui va nous permettre de faire une imbrication de VLANs.

L'idée c'est de regrouper plusieurs VLANs dans un seul et même "super-vlan" qui va être nommé S-VLAN. Les VLANs imbriqués dans le S-VLAN sont appelés C-VLAN.
Le QinQ ajoute quatre octets, dans l'en-tête de la trame Ethernet taguée, répartis sur deux champs :

  • S-TPI : Service Tag Protocol Identifier. Il est codé sur deux octets et permet l'identification du type de trame Ethernet.
    L'IEEE recommande l'utilisation de la valeur 0x88a8, bien que la valeur 0x8100 soit fréquemment utilisée.
  • S-TCI : Service Tag Control Information. Il est codé sur deux octets et permet l'identification du "super-vlan" avec un numéro de tag.

Format de trame Ethernet sous la norme 802.1ad :

dot1ad

Note importante :

L'utilisation du QinQ nécessite que les interfaces concernées puissent activer le Jumbo Frame.

Exemple d'utilisation :

exemple

Configuration CISCO pour encapsulation de VLANs tagués :

Dans cet exemple l'interface interne du site de Paris va encapsuler dans le S-VLAN avec l'outer tag 100 toutes les trames taguées qui passeront par le port fa 0/24.

Configuration du port :

interface FastEthernet0/24
switchport access vlan 100
switchport trunk encapsulation dot1q
switchport mode dot1q-tunnel

Configuration CISCO pour encapsulation de LAN (trafic non-tagué) :

Dans cet exemple l'interface interne du site de Paris va intégrer l'inner tag 5 au trafic non-tagué puis va encapsuler dans le S-VLAN avec l'outer tag 100 toutes ces trames nouvellement taguées.

Configuration du port :

interface FastEthernet0/24
switchport access vlan 100
switchport trunk encapsulation dot1q
switchport trunk native vlan 5
switchport mode dot1q-tunnel